Back to overview
ExamBazar is back online
Jan 01 at 12:15am HST
Affected services
System Health Check
Resolved
Jan 01 at 12:19am HST
The temporary issue affecting ExamBazar has now been fully resolved. All features and services are working normally again.
Thank you for your patience and understanding while we worked on fixing this.
Affected services
Created
Jan 01 at 12:15am HST
The temporary issue affecting ExamBazar has now been fully resolved. All features and services are working normally again.
Thank you for your patience and understanding while we worked on fixing this.
Affected services